易语言哔哩哔哩登陆信息源码

主程序

.版本 2
.支持库 spec

.子程序 BiliLogin, 逻辑型, 公开, 获取登录的二维码、二维码状态链接,并写出登录二维码到运行目录(登录的二维码链接一致
.参数 function, 子程序指针
.局部变量 局_二维码链接, 文本型
.局部变量 局_二维码状态, 文本型
.局部变量 局_返回, 逻辑型

json.解析 (RequestUrl (“https://passport.bilibili.com/x/passport-login/web/qrcode/generate?source=main-web”))
局_二维码链接 = json.取通用属性 (“data.url”)
局_二维码状态 = “https://passport.bilibili.com/x/passport-login/web/qrcode/poll?qrcode_key=” + json.取通用属性 (“data[‘qrcode_key’]”)
json.清除 ()
程序_Call (到整数 (function), 取变量数据地址 (局_二维码链接), 取变量数据地址 (局_二维码状态))
.如果真 (局_二维码链接 ≠ “” 且 局_二维码状态 ≠ “”)
局_返回 = 真
.如果真结束
.如果真 (局_二维码链接 = “” 或 局_二维码状态 = “”)
局_返回 = 假
.如果真结束
返回 (局_返回)

程序集

.版本 2

.子程序 RequestUrl, 文本型, 公开
.参数 url, 文本型
.参数 request, 整数型, 可空
.参数 header, 文本型, 可空
.参数 data, 文本型, 可空
.参数 cookie, 文本型, 可空
.局部变量 局_网址, 文本型
.局部变量 局_方式, 整数型
.局部变量 局_提交数据, 文本型
.局部变量 局_提交cookie, 文本型
.局部变量 ADD_协议头, 类_POST数据类
.局部变量 局_提交协议头, 文本型
.局部变量 局_结果, 字节集
.局部变量 局_返回, 文本型

.如果真 (request ≠ 0 且 request ≠ 1)
request = 0
.如果真结束

.如果真 (header = “”)
header = “User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.87 Safari/537.36”
.如果真结束

局_网址 = url
局_方式 = request
局_提交数据 = data
局_提交cookie = cookie
ADD_协议头.添加 (“User-Agent”, header)
局_提交协议头 = ADD_协议头.获取协议头数据 ()
局_结果 = 网页_访问 (局_网址, 局_方式, 局_提交数据, 局_提交cookie, , 局_提交协议头, , , , , )
局_返回 = 到文本 (编码_编码转换对象 (局_结果))
返回 (局_返回)

全局变量

.版本 2

.全局变量 json, 类_json, , , 精易模块自带类

© 版权声明
THE END
喜欢就支持一下吧
点赞10请喝茶 分享
评论 抢沙发

请登录后发表评论